miércoles, 11 de febrero de 2009

phpBB3: Usando AutoMOD para instalar MODs

Ya que instalamos el AutoMOD en nuestro foro, el siguiente paso es probarlo.

Paso 1: Descarga de MODs


Hay que bajarnos el archivo zip del MOD que queramos instalar, lo descomprimimos y los subimos a la carpeta /store/mods/. Si todo es correcto, al ir a nuestro panel de administración, en el tab de AutoMOD, deben aparecer los MODs que vamos a instalar. Para estas pruebas vamos a instalar el MOD Version Check y el SEO MOD.

[caption id="attachment_404" align="aligncenter" width="300" caption="Instalando MOD con AutoMOD"]Instalando MOD con AutoMOD[/caption]


Paso 2: Instalación de un MOD


Para instalar un MOD, simplemente le damos clic al link de "Instalar" correspondiente a nuestro MOD. Para el ejemplo instalamos primero MOD Version Check.

Inmediatamente después de dar clci se nos muestra una ventana de advertencia sobre lo que vamos a hacer, le damos clic al botón de "Instalar"

[caption id="attachment_405" align="aligncenter" width="300" caption="AutoMOD: Mensaje de advertencia antes de continuar"]AutoMOD: Mensaje de advertencia antes de continuar[/caption]

Después de esto comenzará la instalación, y si todo salió bien, se mostrará un mensaje con un recuadro de fondo verde indicando que todo está bien.

[caption id="attachment_406" align="aligncenter" width="300" caption="AutoMOD: Mensaje de instalación correcta del MOD"]AutoMOD: Mensaje de instalación correcta del MOD[/caption]

y al regresar al tab del AutoMOD aparecerá el MOD isntalado en una lista aparte (incluso dandonos la opción de desinstalar)

[caption id="attachment_407" align="aligncenter" width="300" caption="AutoMOD: Lista de MODs instalados"]AutoMOD: Lista de MODs instalados[/caption]

Paso 3: Si algo salió mal...


En algunos casos algunos archivos no pueden ser subidos o no se pudo hacer un cambio en algunos de los archivos, en este caso al instalar el MOD se nos muestra un mensaje con un recuadro de fondo rojo. Para este ejemplo tratamos de instalar el SEO MOD, que no pudo instalarse correctamente:

[caption id="attachment_408" align="alignnone" width="489" caption="AutoMOD: Errores durante la instalación de un MOD"]AutoMOD: Errores durante la instalación de un MOD[/caption]

Debajo de ese mensaje saldrá marcado en rojo todo lo que no pudo hacer el AutoMOD, que tal vez necesitemos hacer manualmente si queremos terminar la instalación.

[caption id="attachment_410" align="aligncenter" width="459" caption="AutoMOD: Si hay errores en la instalación, saldrán marcados en rojo"]AutoMOD: Si hay errores en la instalación, saldrán marcados en rojo[/caption]

2 comentarios:

  1. llevo 3 horas probando y no hay cojones, al ejecutarse la instalación del seo desde la ACP me empieza a soltar errores de permission denied o unable to acces etc... por si se trataba de permisos mal configurados están a 777 en los archivos que dan fallo y sigue igual...

    ResponderEliminar
  2. Hola,

    Yo no tuve problemas con los permisos. Pero tuve problemas con que el AutoMod no me reconocia las busquedas inline que se marcaban en el archivo xml del SEO mod para su instalacion. Mejor me decidi por un phpBB3 premodificado, con ya cosas de SEO:
    http://www.phpbb-seo.com/en/phpbb-seo-premod/seo-url-premod-t1549.html
    Apenas ahorita lo acabo de instalar y ya pase los datos de la BD al nuevo foro (solo foros, usuarios y topics). Al rato voy a activar los plugins que ya trae preinstalados a ver que tal va.

    Saludos

    ResponderEliminar